公告:

升级Nginx1.9.5以上版本,开启博客网站http2.0时代

作者:我爱技术网 / 时间:1年前 (2018/11/28) / 分类:WEB应用 / 阅读:1781 / 评论:0

最近给我爱技术网全站开启了 https,所以对这块关注比较多。昨天脑补的时候发现 http2.0 只支持 SSL 加密的网站,即 https。于是心血来潮,给我爱技术网开启了 http 2.0,尝尝鲜。

查了下资料,发现 Nginx 不久前发布的 1.9.5 版本支持 http2.0,而 1.8.x 时代只是对 SPDY 进行了支持。一直用的 1.62 稳定版,此次为了测试 http2.0,直接进行了版本跳跃,升级到了 1.9.5 版本,下面简单的分享下部署分解。

Ps:特别说明的是,http2.0 只支持开启了 https 的网站,所以没开启 https 的网站就只能看看了!

升级Nginx1.9.5以上版本,开启博客网站http2.0时代  第1张

一、编译 Nginx

编译 Nginx 是我博客老生常谈的问题,之前都不想赘述的内容,这次还是耐着性子说一下在已有 Nginx 的服务器上重新编译一个 Nginx 的做法。

①、下载 Nginx 最新版

目前 Nginx 最新版是今年 11 月份发布的 1.9.7 版本,反正 1.9+是没有稳定版,所以干脆弄个最新版:

1:cd /usr/local/src      2:wget http://nginx.org/download/nginx-1.9.7.tar.gz

话说 1.9+版本还支持 TCP 负载均衡呢


②、编译 Nginx

在已有环境下编译 Nginx,一般做法是先取得目前运行的 Nginx 的运行参数,然后在这个参数的基础上加上本次编译想新增的参数即可。所以,我们先执行 nginx -V 查看它的编译参数是什么:



推荐阅读:

2019简约美观手机壁纸推荐32微信聊天背景图片大全

快看余额宝跳龙门得最高100万体验金 亲测8元 收益可提现

社保断缴了怎么办?有什么补缴技巧吗?

  • QQ群
  • 微信公众号